Results 1 to 2 of 2

I have a Blackberry 8700g. I need to allow Keystroke Injections in order to be ... Networking with PinStackers forum

  1. #1
    mulvag's Avatar
    mulvag no está en línea Stack level 1
    Join Date
    Feb 2007
    Posts
    1

    keystroke injection denied

    Advertisement



    I have a Blackberry 8700g. I need to allow Keystroke Injections in order to be able to use a Bluetooth wireless keyboard (maker is Freedom) with my Blackberry.On my Blackberry, when I access Security Options - Application Permissions - Edit Permissions - Interactions, Keystroke Injections shows as Denied. I checked on the Blackberry website and it said if I can't change the permissions I need to contact my Blackberry Enterprise Server administrator.I don't know who this is as I obtained the relevant Blackberry from T Mobile on a personal basis, not thru my company. When I contacted T Mobile, assuming T Mobile must be my BES administrator, I was told it is nothing to do withT Mobile. They were pretty unhelpful. But who is the BES administrator? Do I even have one? . I can't find a way of speaking to anyone at Blackberry as their website has no contact telephone numbers. Please can anyone help. I feel like I am in a bit of limbo! If anyone can help, even if just to confirm that there is nothing else I can do, that would be great[FONT=Verdana][/FONT]

  2. #2
    clydebb's Avatar
    clydebb no está en línea Stack level 1
    Join Date
    Feb 2007
    Posts
    2

    Re: keystroke injection denied

    BES stands for Blackberry Enterprise Server. If you work for a corporation that issued you your blackberry, then there's a chance they are running a BES server. If it's a personal blackberry, then most likely you are not on a BES. If you are on a BES, then the BES Administrator needs to push down a policy that will allow Event Injections. Hopefully they should know how to do this. If you aren't on a BES, (and even if you are this is worth a shot) you can do the following

    1. On your Blackberry check in "options"-->"Advanced options".

    2. highlight "Blackberry Core Applications", click it once, then choose Modules.

    3. find the module for your bluetooth keyboard (it varies depending on the make and model, your manual might say more) and click it, then choose "edit permissions".

    4. you will see "Connections", "Interactions", and "User data". go to "Interactions", click it, and choose expand.

    5. you should see "keystroke injection", which by default is set to deny. change this to allow and save your settings. if it will not let you change from deny to allow, then you are likely on a BES, and an administrator will have to assist you

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •