Results 1 to 7 of 7

How can I prevent my Blackberry from correcting my typing with foreign lanuguage charaters? For ... RIM Blackberry 71xx forum

  1. #1
    shreve121764's Avatar
    shreve121764 no está en línea Stack level 1
    Join Date
    Apr 2008
    Posts
    3

    Question Autocorrect errors

    Advertisement



    How can I prevent my Blackberry from correcting my typing with foreign lanuguage charaters? For instance, if I am typing an email address, and I am adding .com to the end, I would NEVER want it to autocorrect it to .com with some kind of strange squiggly line hanging off of the bottom of the "c". I just sent an email last night, and it was returned to me because no email service uses this .com with the strange squiggly line hanging off of the bottom of the "c". This happens quite often while I am typing, and the autocorrect options come up with an "e" with an accent mark, or an "o" with strange accents. My language selections are all United States English, so why do I get these other non-English, non-26-character-alphabet characters as options while I am typing?

    United States English has 26 characters. How do I set it up to use only those? This is so annoying, mainly because the screen is so small and these accents that are placed on characters aren't even big enough to see, and certainly aren't expected, so I don't look for them too carefully until something fails and is returned to me.

  2. #2
    archer6's Avatar
    archer6 no está en línea Stack level 8
    Join Date
    Oct 2006
    Posts
    4,996
    Please go to your profile and fill out which BlackBerry model you are using and what carrier you are on. This way we can be of more assistance to you. We will know if it's a qwerty keyboard model or a SureType keyboard model.

    Because you have not listed which model of BlackBerry you are using I am going to you an answer which applies to SureType keyboards which are not the full size qwerty keyboard.

    SureType supports English, French, German, Italian, Spanish, and I am sure RIM will be adding more in the future.

    You can change your input language by going to:
    Options –> Language –> Input Method –> Select Language –> TrackBall or Trackwheel-click and Save.

    Let us know if that works for you. Remember the more specifics you give us the better we can assist you.

    Cheers!


  3. #3
    shreve121764's Avatar
    shreve121764 no está en línea Stack level 1
    Join Date
    Apr 2008
    Posts
    3
    Mine is a 7130c, and my languages were already set to English (United States).

  4. #4
    archer6's Avatar
    archer6 no está en línea Stack level 8
    Join Date
    Oct 2006
    Posts
    4,996
    Quote Originally Posted by shreve121764 View Post
    Mine is a 7130c, and my languages were already set to English (United States).
    -----
    Ok, my personal experience with my 7130c has been exactly the same as what you are experiencing now.

    Here's what's happening, by mistake when one is learning SureType it's possible to hit the wrong key combination to change the input language, without realizing it until you see the strange character output.

    So even though it was correct in the beginning, go back and you will find it's changed. Simply change it back & you will be OK.

    Let me know how you do.

    Cheers!

  5. #5
    BenMarvin's Avatar
    BenMarvin no está en línea Device Pro
    Join Date
    Jan 2006
    PIN/ID
    Ask Me!
    Posts
    1,970
    You can start over by clearing the custom word list. It's in the options. I remember when I had a 7100, there was some weird stuff that ended up in there. You make a typo once and it adds it to the list. If you clear the wordlist, the phone will "learn" your typing habits from scratch.

    Also, I moved this thread over to the 71xx forum, as you may get more advice from that area.

  6. #6
    archer6's Avatar
    archer6 no está en línea Stack level 8
    Join Date
    Oct 2006
    Posts
    4,996
    Quote Originally Posted by BenMarvin View Post
    I moved this thread over to the 71xx forum, as you may get more advice from that area.
    Great idea, Thanks!

    via: BlackBerry 8310

  7. #7
    shreve121764's Avatar
    shreve121764 no está en línea Stack level 1
    Join Date
    Apr 2008
    Posts
    3
    My language is still set to English (United States).

    Please note that I don't care about this when I am typing the text of a message, since it is still possible to read the message whether, for instance I type "not" and it isn't auto-edited or if I type "not" and the "o" is changed to something with an accent such as... n[FONT=Times New Roman]öt [/FONT], or some other extended ASCII character, so I just lived with it.

    But this is the first time that it happened when typing in an email address, as just happened, with the ".com" being changed to .[FONT=Times New Roman]çom[/FONT], where the "c" had a tail hanging off of it, Microsoft Windows extended character 0231, or E7 below

    [FONT=Times New Roman] .çom[/FONT]

    In this case the email was not sent because that is not a valid email address, and my project was delayed because I didn't know that the other end hadn't received the email until I received the failure report.

    When I first noticed this happening I checked my custom word list and didn't find any strange characters in there. I have just checked it again, and didn't find anythign wrond, but I have just deleted my custom word list in case I missed something.

    Is there some way to prevent the Blackberry from using any of these extended ASCII characters, or any other ASCII characters other than 0-9, a-z, and A-Z? Can't Blackberry give this to us as an option. I would bet that 99.999% of people who type emails and use their Blackberry in the United States would want this. If it is an option, then those that don't want it could select another option. I can't think of any need that I have outside of these 0-9, a-z, and A-Z characters, and the normal punctuation marks, when using my Blackberry. Call it the "SHREVE ENGLISH" option. Can we create our own custom language to exclude any characters that we don't want to use, just like a custom word list?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •