Results 1 to 5 of 5

Hi, I have been using my blackberry 7105t from almost 6 months and before used ... RIM Blackberry 71xx forum

  1. #1
    navijohal's Avatar
    navijohal no está en línea Stack level 1
    Join Date
    Jan 2007
    Posts
    13

    Lightbulb 7105t Won't Turn On...

    Advertisement



    Hi, I have been using my blackberry 7105t from almost 6 months and before used old one. I signed up and installed the BB-Zen theme over the air, now i turned my black berry on and there was no option or setting button. So, i turned it off. But when i turned it on again, it won't the wait sign is been like that from 3 hrs. I tried removing battery and putting back in but no use.. I'm so confused right now that i feel like breaking it..

  2. #2
    cp6169's Avatar
    cp6169 no está en línea Device Pro
    Join Date
    Mar 2006
    PIN/ID
    3056468b
    Posts
    14,661

    Re: 7105t Won't Turn On...

    Hi navijohal, welcome to pinstack.

    First take out your battery and hold the power button down for 30 seconds. Then replace the battery and hopefully your BB powers up. If not we will go from there...

  3. #3
    navijohal's Avatar
    navijohal no está en línea Stack level 1
    Join Date
    Jan 2007
    Posts
    13

    Re: 7105t Won't Turn On...

    No, It didn't work it is still the same wait sign keeps revolving for ever and ever... Any help before i get mad and break it..

  4. #4
    boomboom's Avatar
    boomboom no está en línea Stack level 3
    Join Date
    Jan 2007
    PIN/ID
    retired
    Posts
    486

    Re: 7105t Won't Turn On...

    ~via BB (wap.pinstack.com)~it sounds like you need to reinstall your OS. Do a quick search for "how to reinstall your os when it won't power up" I am on my BB right now so I don't have the link right now

  5. #5
    navijohal's Avatar
    navijohal no está en línea Stack level 1
    Join Date
    Jan 2007
    Posts
    13

    Re: 7105t Won't Turn On...

    It worked! Its working again! I pressed like all the buttons at same time, it turned off and turned back on in defulat mode. Thanks!!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •