Results 1 to 11 of 11

Before I finally go for it...Question? I have an 8830 WE with Verizon Wireless. Are ... BlackBerry 8830 forum

  1. #1
    BraveGiant's Avatar
    BraveGiant no está en línea Stack level 1
    Join Date
    Nov 2007
    Posts
    15

    Verizon 8830 WE Upgrade Ques.

    Advertisement



    Before I finally go for it...Question? I have an 8830 WE with Verizon Wireless. Are the 4.5 updates from Sprint and Other Services talked about in these forums safe to use on a Verizon Phone? I know about deleting vendor file, but Verizon is famous for some pretty tight lock downs. If a couple of fellow Verizon stackers can tell me their experience, I would appreciate it.

  2. #2
    bbfogie's Avatar
    bbfogie no está en línea Stack level 2
    Join Date
    Sep 2007
    Posts
    37
    I have upgraded to a couple of different version 4.5 builds and have no problems with my VZW 8830.

  3. #3
    LarryF's Avatar
    LarryF no está en línea Stack level 1
    Join Date
    Dec 2007
    Posts
    13
    I, too, have the Verizon 8830 and have been similarly frustrated. I first upgraded a couple of months ago with the Beta 4.5.101 and had no problems. Last week I further upgraded with the Sprint release and it worked fine. The only other thing I can offer is at my first upgrade I also upgraded the Desktop Manager to the 4.5 version. Good Luck.

  4. #4
    EricaJ1073's Avatar
    EricaJ1073 no está en línea PINStacked!
    Join Date
    Mar 2006
    Posts
    10,420
    As long as it's for the 8830 device, then you should be ok. Just don't use DM 4.7. It's WAY too buggy.


  5. #5
    moderncowboy's Avatar
    moderncowboy no está en línea Stack Moderator
    Join Date
    May 2008
    PIN/ID
    AskMe
    Posts
    7,297
    BraveGaint,
    You can use any OS from any carrier to upgrade. If you are willing to take the plunge then I would suggest going with the Sprint 4.5.0.135 found here. I am not with Verizon but just upgraded my daughters BF Alltel 8830 this weekend using it and had no issues. As long as you delete then vendor.xml it should be fine.

    I would also suggest backing up your device and using jl_cmndr to wipe your device. You might have to reinstall a few apps but it is worth it. Even if you chose not to wipe it make sure you use DM 4.6 or the loader.exe in the app loader folder and not 4.7. You shouldn't have any problems and if you do there is pleanty of support here for you. Also remember to remove you memory card before starting.

  6. #6
    pick3222's Avatar
    pick3222 no está en línea Stack level 1
    Join Date
    Jun 2008
    Posts
    6
    I have upgraded my vzn 8830 twice with version 4.2.x.x and three more times with version 4.5 (4.5.0.51; 4.5.0.127; 4.5.0.135) and all has been well. I have done wipes with fresh installs and I have installed over top of a pre-existing version - no problems other than what I have messed up.

    One suggestion: BACK UP your data, and back up your 3rd party apps FIRST.

  7. #7
    reddrvgon's Avatar
    reddrvgon no está en línea Stack level 8
    Join Date
    Nov 2007
    PIN/ID
    ask me
    Posts
    6,417
    Just another little tidbit of info... Many many people have upgraded their Storm OS to the available BETA releases with no issues...
    ~via smartphone mobile.pinstack.com~

  8. #8
    visortgw's Avatar
    visortgw no está en línea Stack level 3
    Join Date
    Apr 2007
    Posts
    205

    Lightbulb

    Suggestions for the upgrade...

    Before performing the upgrade, backup your device data using the Backup and Restore utility of the Desktop Manager as well as 3rd-party apps using the Device Switch Wizard utility of the Desktop Manager (when the utility asks for the new device, find the app backup in "C:\Documents and Settings\[user]\Local Settings\Tmp\[devicepin] or similar, and copy to another location).

    Use the AppLoader (C:\Program Files\Common Files\Research in Motion\AppLoader\Loader.exe or similar, i.e., Loader.exe in the same directory as the Vendor.xml) directly to perform the upgrade process as opposed to the Desktop Manager. From personal experience (as well as confirmation from others), this tends to go much more smoothly.

  9. #9
    bbfogie's Avatar
    bbfogie no está en línea Stack level 2
    Join Date
    Sep 2007
    Posts
    37
    I used DM ver. 4.7 to install .135 and had no issues. Maybe I just got lucky? I did backup first.

  10. #10
    MotoUp's Avatar
    MotoUp no está en línea BES Pro
    Join Date
    Nov 2006
    Posts
    3,360
    I recently upgraded to 8830's using Sprint's OS. The upgrades went flawless. I say go for it. It's an official release, and they are very pleased with the updated features.

  11. #11
    mrvtx's Avatar
    mrvtx no está en línea Stack level 2
    Join Date
    Aug 2007
    Posts
    53
    I also upgraded the Sprint version to my VZW 8830 using DM 4.7 with no problem. Just installed over, no wipe, but backed up. 4.7 does that automatically during the install process.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •