Page 2 of 2 FirstFirst 12
Results 16 to 17 of 17

I have a problem with telenav... I was using it for a month (or something-free ... BlackBerry 8830 forum

  1. #16
    BBmn2s's Avatar
    BBmn2s no está en línea Stack level 1
    Join Date
    Oct 2007
    Posts
    6

    Re: TeleNav 5.1 on 8830 BT GPS?

    Advertisement



    I have a problem with telenav... I was using it for a month (or something-free trial) and it was perfect. after that, it asked me do I want to subscribe and I said Yes,and if offered me to download a new software which I did. And now, it doesn't work. It says "cannot connect to server"....Trust me, I've tried everything, I changed password, I uninstalled and installed telenav few times, take off the battery...everything....and it still doesn't work. In t-mobile they say they don't know that and that I should call TeleNav, TeleNav says it is not their fault...Now I'm using google maps, but I don;t like them that much........
    Any idea how to solve problem?
    Thank you!

    it's 8800
    Last edited by BBmn2s; 10-22-2007 at 05:56 AM. Reason: Automerged.

  2. #17
    TreBlack7's Avatar
    TreBlack7 no está en línea Stack level 2
    Join Date
    Jul 2007
    Posts
    36

    Re: TeleNav 5.1 on 8830 BT GPS?

    This may take a while but you should see if you can get a TeleNav rep to call TMobile while you are on the phone with him/her and get it resolved. I had some help last week this way and my issue was resolved pretty quickly this way. Your chances are much higher this way because TeleNav reps are "motivated" to make sure they have new subscribers up and running. I'm on Sprint, but I know for a fact that when it comes to having new subscribers locked in, ANY TeleNav rep is likely to be a lot more helpful in this area than your carrier rep.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •