I just did it on an 8800 and it worked perfectly. The only thing I'd change for the 8800 is to change the steps to:

1. Settings
2. Options
3. Mobile Network
4. Set "Data Services" to "off"
5. Save
6. Go back to main menu
7. Turn wireless off and then back on.

Worked perfectly.