Results 1 to 11 of 11

We are using IMAP (BIS) to get emails ( Microsoft Exchange. no BES) Problem is ... BlackBerry Internet & Email forum

  1. #1
    rima's Avatar
    rima no está en línea Stack level 1
    Join Date
    Oct 2007
    Posts
    2

    Question Duplicate email messages

    Advertisement



    We are using IMAP (BIS) to get emails ( Microsoft Exchange. no BES)

    Problem is say, I receive an email in my Outlook from the Exchange Server and my Blackberry at the same time. If I look at the message today or next week, it will duplicate the message on the Blackberry only. If I reply to an email, I get the same email back as the orginal without my comments. This is also through different cariers, ATT, Verizon and Tmobile.

    Please Help.

    Thanks

  2. #2
    BombaMyte's Avatar
    BombaMyte no está en línea Stack level 2
    Join Date
    Sep 2007
    PIN/ID
    240B992D
    Posts
    56

    Re: Duplicate email messages

    You need to filter your email address in BIS. Then you shouldn't get the duplicate back on your BB. Depending, the filter should say something like "do not send email to (email addy)". I use GMail to push to my BB through BIS, so I'll look at the filter there and on BIS (I think my filter is on my BIS) to get you the exact wording.
    ~via BombaBerry (wap.pinstack.com)~

  3. #3
    rima's Avatar
    rima no está en línea Stack level 1
    Join Date
    Oct 2007
    Posts
    2

    Re: Duplicate email messages

    Thanks BombaMyte for the comment but filter thing did not work in my case. I traced the issue and its related to Exchange server. server changes the UID of the message after reply so BIS sees it as a new message hence duplicate mail on the device. If you or anybody have some other ideas please let me know.

    Thanks!

  4. #4
    Agent Orange's Avatar
    Agent Orange no está en línea Stack level 1
    Join Date
    Oct 2007
    Posts
    3

    Re: Duplicate email messages

    I would like to know how to turn this off too. having the same problem with gmail.

  5. #5
    Keyscan's Avatar
    Keyscan no está en línea Stack level 2
    Join Date
    Nov 2007
    Posts
    28

    Re: Duplicate email messages

    Quote Originally Posted by rima View Post
    Thanks BombaMyte for the comment but filter thing did not work in my case. I traced the issue and its related to Exchange server. server changes the UID of the message after reply so BIS sees it as a new message hence duplicate mail on the device. If you or anybody have some other ideas please let me know.

    Thanks!

    There is a specific revision of exchange 2003 where this is happening with by the looks of it. The way around this is to setup a forwarding rule on your mail server and have the email forward to a BlackBerry hosted email address.

    Only integrations that poll by UID's are susceptible to this issue.

  6. #6
    jonnyg75's Avatar
    jonnyg75 no está en línea Stack level 1
    Join Date
    Oct 2006
    Posts
    9
    Quote Originally Posted by Keyscan View Post
    There is a specific revision of exchange 2003 where this is happening with by the looks of it. The way around this is to setup a forwarding rule on your mail server and have the email forward to a BlackBerry hosted email address.

    Only integrations that poll by UID's are susceptible to this issue.
    I'm having the exact same problem, but I don't want to forward messages from exchange using a rule. Its there a patch for Microsft to address this?

    What did you mean by "integrations that poll by UID", are the integrations that don't use UID, or do you mean all IMAP integrations?

  7. #7
    Walter Mitty's Avatar
    Walter Mitty no está en línea Stack level 1
    Join Date
    Apr 2008
    Posts
    5
    I too am having the same issue. We're on exchange and when i get an email, both my outlook 2007 and Blackberry Curve 8310 get this original email. If i respond in outlook to this email I will receive another copy of the original email on my Blackberry after a few minutes. The only difference is now it has a different RefID number (which i learned about after calling RIM) so it's treated as a new email. Somehow during this process it appears that outlook/exchange is changing its RefID number??? Any assistance would be GREATLY appreciated as i'm on outlook alll day and it's really cluttering up my Blackberry inbox! TIA.

  8. #8
    Walter Mitty's Avatar
    Walter Mitty no está en línea Stack level 1
    Join Date
    Apr 2008
    Posts
    5
    btw, i found this on another site. It didn't work for me but i do have our IT guys looking in to it:

    I've been using my Blackberry VZW Pearl with BIS to access my company's Exchange email via IMAP since about November.

    Some time in early January, I started getting duplicate emails on my work email account. If I forwarded or replied to an email, or even just set a reminder flag on it, the original email was re-sent to my blackberry. Like this:

    * I received an email
    * It appeared in outlook and on my blackberry
    * I replied to, or flagged the message for follow-up, or forwarded it using Outlook
    * The original message appeared again on my blackberry

    It would even happen if I simply opened an email in Outlook for a few of minutes.

    I had tried all sorts of things to fix it, things I thought of, suggestions from others here, spent a couple hours on the phone w/Verizon support, and none of them worked.

    I was futzing around with this tonight after spending more frustrating time going through and removing dupes from my BB, and decided to delete and add my work email account again. I'd done that about 6 or 7 times already w/no change, but what the heck, I'm an optimist.

    When I deleted and added my work email account, the VZW BIS site selected a different server than it had before.

    Originally the BIS site had selected:

    - mail.cce.companydomain.com

    After dupes started arriving I manually changed to the server name below to see if that would help. It didn't, still got dupes.

    - mail.companydomain.com

    Today, when I deleted and re-setup my work email account on the VZW BIS site, it selected an entirely new and unknown (to me) server:

    - https://sync.companydomain.com

    Since this change about three hours ago, I've had zero dupes on my BB!

    I don't know enough about exchange and BIS to know if the server name formats are "generic" across companies, but I was hoping that others having this very annoying duplicate email problem could try using a server name w/the above format to get the same relief.

    Appreciate it if others w/more experience/expertize in this area could chime in - but it might be that if you are having this problem, you could try editing your Advanced Settings for your email account on your providers BIS site and set your server to https://sync.yourcompanydomain.com and see if it works/helps.

  9. #9
    markgallant's Avatar
    markgallant no está en línea Stack level 3
    Join Date
    Sep 2007
    Posts
    430
    It is something in the exchange environment where when you modify an email. And by modify I mean reply, forward, read etc. it isn't just changing the status of the email it is completely changing the refid. Therefore when the BlackBerry servers poll your email it sees a new refid and sends it down to the blackberry device. You need to talk with your Exchange admins and have them look into why it is changing the id's of the emails.

  10. #10
    Walter Mitty's Avatar
    Walter Mitty no está en línea Stack level 1
    Join Date
    Apr 2008
    Posts
    5
    Quote Originally Posted by markgallant View Post
    It is something in the exchange environment where when you modify an email. And by modify I mean reply, forward, read etc. it isn't just changing the status of the email it is completely changing the refid. Therefore when the BlackBerry servers poll your email it sees a new refid and sends it down to the blackberry device. You need to talk with your Exchange admins and have them look into why it is changing the id's of the emails.
    Thank you Mark. I really think this is the issue but i wonder why it's just on my server. We have two seperate servers here as we have two seperate companies sharing an office. My associates on the other server show no duplicates and we have the exact same setup apparently. Any ideas?

  11. #11
    ischlachter's Avatar
    ischlachter no está en línea Stack level 1
    Join Date
    May 2008
    Posts
    1

    This fix WILL work... Thank God

    Problem:
    I had this exact duplicate email issue at my work as well. Anytime the user would read an email from the Outlook Inbox it would resend the email to the device as new mail. It would also send sporatic duplicate emails to the handheld device.
    We initially setup our accounts as internet mail accounts and let the AT&T and TMobile websites configure most of the configuration. That was our problem..

    Solution:
    Log on to either the AT&T or TMobile website. Delete your present email account.
    Go to Setup Email: Don't enter your real email account, you'll have to fool the site into letting you manually configure the information. (Example: If your email address is Ivan@darkcorp.com, just type ivan@dc.com)
    After it is unable to recognize the email it will give you this option I will provide the settings to add this email account. Choose this option and click next.
    Choose either work email account.
    Then choose Outlook® / Exchange®
    This is a Critical part:
    In the Outlook® Web Access URL: you would usually enter your Exchange proxy server.(Example: email.darkcorp.com) Instead, enter it in this format (https://email.darkcorp.com/Exchange)
    For User name: type your (domain name\AD account name) (Example: Dark\Ivan)
    For Mailbox name type you AD name.

    This will work...
    Last edited by ischlachter; 05-14-2008 at 06:45 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •