Results 1 to 12 of 12

I installed Kubuntu 7.10 and after a bit of tinkering, I was able to get ... Linux OS forum

  1. #1
    tavella81's Avatar
    tavella81 no está en línea Stack level 3
    Join Date
    Sep 2007

    Bluetooth DUN tethering - Linux and KDE (Might work with Gnome)


    I installed Kubuntu 7.10 and after a bit of tinkering, I was able to get my Sprint 8830 to tether my connection via Bluetooth.

    I'm not sure how to make this work exactly with Ubuntu/Gnome only, so maybe some of this information will assist you in your journey.

    First I made sure BlueZ was installed. I went through Synaptic and made sure everything BlueZ was installed and alot of other Bluetooth software I could locate (hcitool, sdp, rfcomm, etc).

    I then ran:
    hcitool scan
    This gave me the (I guess it's a MAC address) of the 8830. I then ran the following commands:
    hcitool cc MACADDRESS
    hcitool auth MACADDRESS
    I then received a pop-up from KDE-Pin helper (or something similar to that name. I forgot the name of the program. In Vista right now sorry).

    I entered a PIN and then my phone asked for the verification. I did this an allowed the PC to access the phone anytime.

    I then ran sdptool to browse for the services. I did not locate any service for BT DUN so I started using all of the channels with rfcomm and found that channel 3 which was listed as a voice channel actually created a usable /dev/rfcomm0. I created the connection with the following command:

    rfcomm bind hci0 MACADDRESS 3
    If this doesn't work after trying to access the port with KPPP do the following:

    rfcomm release hci0
    At this point, try another channel and try KPPP again. At some point you will get the right one and it will stop telling you that /dev/rfcomm0 cannot be opened.

    I then created a profile in KPPP with Sprint as the ISP (I'm sure it will work with other providers if you know the dialup number). I believe CDMA uses #777 and GSM uses *99*? It's been a while.

    For my username, I used my user name issued by sprint and the password I use to login to their website. I really don't think it matters what you use with Sprint. Not sure about Alltel or VZW.

    To make sure your connection is not dropped after a few minutes go to /etc/ppp and edit the options file. Do a search the following lines and comment them out with a #:

    lcp-echo-failure 4  
    lcp-echo-interval 30

    I had to do this with my Moto Q as it would not respond to the LCP ping requests and it would disconnect after four failed attempts. I did not appear to have this problem with the 8830 but did it just in case.

    I did receive pretty bad ping responses and my max speed was only like 200-300kb/s but it was functional. I hope this helps until someone can come up with a USB driver, a tool like Moto4Linux, or RIM actually releases something for Linux. Feel free to PM me if you have any questions.
    Last edited by tavella81; 01-26-2008 at 09:54 PM.

  2. #2
    tavella81's Avatar
    tavella81 no está en línea Stack level 3
    Join Date
    Sep 2007

    Re: Bluetooth DUN tethering

    I believe when I hit channel 6, my phone thought it was connecting to the desktop manager and the phone said "Connecting to PC". I'm not sure if anyone has tried to reverse engineer the communications from the phone in order to allow BT syncing with the phone. I haven't tried XMBlackBerry or Barry so I don't know if this already exists.

  3. #3
    mistermix's Avatar
    mistermix no está en línea Stack level 1
    Join Date
    Jan 2008

    Thumbs up Re: Bluetooth DUN tethering

    Thanks for the tip. I'm running Ubuntu 7.10 and it worked for me on a Dell XPS M1210 laptop and a Verizon 8830. Here are the differences between Kubuntu and Ubuntu. The following assumes you have bluetooth working on your Ubuntu system (in other words, the blue "B" is visible in your system tray).

    The Ubuntu graphical bluetooth tools work well for associating the computer and blackberry. In bluetooth preferences, accessed from the Gnome system menu, make sure your bluetooth adapter is "Visible and connectable".

    Then, go into the bluetooth settings on the Blackberry and initiate a connection to the computer. Enter a passcode on the blackberry. The "B" icon on the system tray will flash a message saying the blackberry is requesting access. Write down the MAC address and enter the passcode.

    To test tethering, enter the following command, where MACADDRESS is the MAC address written down from the connect dialog.

    rfcomm bind hci0 MACADDRESS 3
    Then, click on your network manager icon in the task tray and select "Manual Configuration". Select Properties on Modem Settings. In that dialog, on the General tab, enable the connection and put in the phone number and username/password info. I'm on Verizon so I used #777 for the phone, and for the username/password, where xxxxxxxxxx is my Verizon phone number. Then select the Modem tab, and set the modem device to /dev/rfcomm0. In options, check the default route and use internet provider name servers options. Then close the dialog.

    After you've done this, be sure you're disconnected from all other networks. Click on the network manager icon in the task tray, select Dial Up connections, and select "Connect to ppp0 via Modem". The bluetooth light should begin blinking on your blackberry, and the Modem Mode indicator will show up.

    When you're done, click on network manager/Dial Up connections/ Disconnect from ppp0 via Modem.

    To make this permanent, as superuser, edit /etc/bluetooth/rfcomm.conf and set it as follows:

    # RFCOMM configuration file.
    rfcomm0 {
            # Automatically bind the device at startup
            bind yes;
            # Bluetooth address of the device
            device MACADDRESS;
            # RFCOMM channel for the connection
            channel 3;
            # Description of the connection
            comment "Blackberry DUN";
    Replace MACADDRESS in the above with the MAC address of your blackberry.

    I was also able to get OBEX file transfer working for pictures in the Media Player by installing gnome-bluetooth.

  4. #4
    Yogich's Avatar
    Yogich no está en línea Stack level 3
    Join Date
    Jun 2007
    Kubuntu 7.10 is Gutsy, is it not? Interesting find. Will have to give this a try.

    [Later] I can connect, but cannot surf. Wondering about DNS & how that was handled. Old thread, so won't hold my breath. lol
    Last edited by Yogich; 04-27-2008 at 08:56 PM.

  5. #5
    ConstantineXVI's Avatar
    ConstantineXVI no está en línea Stack level 3
    Join Date
    Mar 2008
    ...wait, someone got this going? Must investigate myself. I'm running 8.04 (hardy), will see what I can cook up.

  6. #6
    Yogich's Avatar
    Yogich no está en línea Stack level 3
    Join Date
    Jun 2007
    I'm not certain that anyone using a BlackBerry, has gotten it going. I've been trying, for several days. There is a critical piece of information missing far as getting on TMO (USA) via BlackBerry, is concerned.

    Channel 3 is the voice channel, over which phone calls are made. Channel 4 seems to be the correct one, but I have been unable to make a hopefully intelligent guess as to which of the how-many-channels(?) is used. Those I have tried, failed, except for channel 4, which actually had the blue light responding to...
    # echo "ATZ" >/dev/rfcomm0
    Still... that doesn't mean it is necessarily the correct one --even though I seem to be connecting. There is the damned Avahi DHCP daemon that keeps bringing up eth0 & trying to feed it the IP address. There is something very wrong with this picture. I posted a thread on it:

    I've been all over the internet and have found only one BlackBerry-based URL, and only saved the page so I no longer have it. The key I used in Google: "tethering with linux" ...including the quotations.

    I could definitely use some help. TMO was some help, with IP addresses, and such, but so far it has been a bust.
    Last edited by Yogich; 05-01-2008 at 07:02 PM.

  7. #7
    tavella81's Avatar
    tavella81 no está en línea Stack level 3
    Join Date
    Sep 2007

    I wish I still had PAM on my BB it would make this a little easier. Did you run sdptool scan <macaddress>? Channel 3 never displayed on my phone so I went ahead and tried it anyways but for some reason, rfcomm is now causing kernel panics with Hardy.... I must have really messed it up lol.. I'll keep trying and see how far I get. I have a friend with an 8100 on T-mobile. When she comes around, I'll see if she'll let me try to get it to connect.

    Ok, so I've been playing around with my phone and I'm successfully creating /dev/rfcomm0 by using rfcomm bind hci0 <macaddress> <channel #> but the following keeps shows up in dmesg:

    [ 244.419674] rfcomm_tty_ioctl: TIOCGSERIAL is not supported
    [ 255.235830] rfcomm_tty_ioctl: TIOCGSERIAL is not supported

    I'm at a loss at this point. Will research the message.

    This could be a problem with rfcomm or the kernel from what I've found so far.... I did this originally when Gutsy was beta.
    Last edited by tavella81; 05-01-2008 at 09:52 PM.

  8. #8
    tavella81's Avatar
    tavella81 no está en línea Stack level 3
    Join Date
    Sep 2007
    Here is my kernel panic:

    [ 636.351186] WARNING: at /build/buildd/linux-2.6.24/fs/sysfs/dir.c:424 sysfs_add_one()
    [ 636.351192] Pid: 8157, comm: rfcomm Tainted: P 2.6.24-16-generic #1
    [ 636.351195]
    [ 636.351196] Call Trace:
    [ 636.351229] [<ffffffff802fe418>] sysfs_add_one+0xb8/0xf0
    [ 636.351237] [<ffffffff802ff413>] sysfs_create_link+0xa3/0x140
    [ 636.351253] [<ffffffff803b7b09>] device_add+0x189/0x5d0
    [ 636.351264] [<ffffffff80344912>] kobject_get+0x12/0x20
    [ 636.351276] [<ffffffff803b82c8>] device_create+0xe8/0x140
    [ 636.351287] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 636.351306] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 636.351327] [<ffffffff8039330b>] tty_register_device+0x6b/0x100
    [ 636.351335] [<ffffffff802909e2>] handle_mm_fault+0x1b2/0x7b0
    [ 636.351344] [<ffffffff802a77a7>] kmem_cache_alloc+0x67/0xa0
    [ 636.351350] [<ffffffff802a77a7>] kmem_cache_alloc+0x67/0xa0
    [ 636.351367] [<ffffffff88cd1ed5>] :rfcomm:rfcomm_dev_ioctl+0x5f5/0x730
    [ 636.351378] [<ffffffff80464730>] do_page_fault+0x1d0/0x840
    [ 636.351395] [<ffffffff88ccfd94>] :rfcomm:rfcomm_sock_ioctl+0x34/0x60
    [ 636.351405] [<ffffffff803d792f>] sock_ioctl+0xcf/0x260
    [ 636.351416] [<ffffffff802bb06f>] do_ioctl+0x2f/0xa0
    [ 636.351424] [<ffffffff802bb300>] vfs_ioctl+0x220/0x2c0
    [ 636.351430] [<ffffffff802ab285>] fd_install+0x25/0x60
    [ 636.351441] [<ffffffff802bb431>] sys_ioctl+0x91/0xb0
    [ 636.351454] [<ffffffff8020c37e>] system_call+0x7e/0x83
    [ 636.351615]
    [ 642.286106] sysfs: duplicate filename 'rfcomm0' can not be created
    [ 642.286116] WARNING: at /build/buildd/linux-2.6.24/fs/sysfs/dir.c:424 sysfs_add_one()
    [ 642.286122] Pid: 8181, comm: rfcomm Tainted: P 2.6.24-16-generic #1
    [ 642.286125]
    [ 642.286126] Call Trace:
    [ 642.286159] [<ffffffff802fe418>] sysfs_add_one+0xb8/0xf0
    [ 642.286167] [<ffffffff802fea30>] create_dir+0x60/0xb0
    [ 642.286182] [<ffffffff802feab1>] sysfs_create_dir+0x31/0x50
    [ 642.286190] [<ffffffff80344912>] kobject_get+0x12/0x20
    [ 642.286197] [<ffffffff80344f23>] kobject_add+0xb3/0x200
    [ 642.286208] [<ffffffff803b7a4f>] device_add+0xcf/0x5d0
    [ 642.286217] [<ffffffff80344912>] kobject_get+0x12/0x20
    [ 642.286229] [<ffffffff803b82c8>] device_create+0xe8/0x140
    [ 642.286240] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 642.286259] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 642.286280] [<ffffffff8039330b>] tty_register_device+0x6b/0x100
    [ 642.286294] [<ffffffff802a77a7>] kmem_cache_alloc+0x67/0xa0
    [ 642.286311] [<ffffffff88cd1ed5>] :rfcomm:rfcomm_dev_ioctl+0x5f5/0x730
    [ 642.286322] [<ffffffff80464730>] do_page_fault+0x1d0/0x840
    [ 642.286339] [<ffffffff88ccfd94>] :rfcomm:rfcomm_sock_ioctl+0x34/0x60
    [ 642.286349] [<ffffffff803d792f>] sock_ioctl+0xcf/0x260
    [ 642.286360] [<ffffffff802bb06f>] do_ioctl+0x2f/0xa0
    [ 642.286368] [<ffffffff802bb300>] vfs_ioctl+0x220/0x2c0
    [ 642.286374] [<ffffffff802ab285>] fd_install+0x25/0x60
    [ 642.286385] [<ffffffff802bb431>] sys_ioctl+0x91/0xb0
    [ 642.286398] [<ffffffff8020c37e>] system_call+0x7e/0x83
    [ 642.286417]
    [ 642.286422] kobject_add failed for rfcomm0 with -EEXIST, don't try to register things with the same name in the same directory.
    [ 642.286429] Pid: 8181, comm: rfcomm Tainted: P 2.6.24-16-generic #1
    [ 642.286431]
    [ 642.286432] Call Trace:
    [ 642.286440] [<ffffffff80344fb9>] kobject_add+0x149/0x200
    [ 642.286451] [<ffffffff803b7a4f>] device_add+0xcf/0x5d0
    [ 642.286459] [<ffffffff80344912>] kobject_get+0x12/0x20
    [ 642.286471] [<ffffffff803b82c8>] device_create+0xe8/0x140
    [ 642.286481] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 642.286500] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 642.286519] [<ffffffff8039330b>] tty_register_device+0x6b/0x100
    [ 642.286532] [<ffffffff802a77a7>] kmem_cache_alloc+0x67/0xa0
    [ 642.286547] [<ffffffff88cd1ed5>] :rfcomm:rfcomm_dev_ioctl+0x5f5/0x730
    [ 642.286556] [<ffffffff80464730>] do_page_fault+0x1d0/0x840
    [ 642.286572] [<ffffffff88ccfd94>] :rfcomm:rfcomm_sock_ioctl+0x34/0x60
    [ 642.286581] [<ffffffff803d792f>] sock_ioctl+0xcf/0x260
    [ 642.286591] [<ffffffff802bb06f>] do_ioctl+0x2f/0xa0
    [ 642.286599] [<ffffffff802bb300>] vfs_ioctl+0x220/0x2c0
    [ 642.286605] [<ffffffff802ab285>] fd_install+0x25/0x60
    [ 642.286615] [<ffffffff802bb431>] sys_ioctl+0x91/0xb0
    [ 642.286627] [<ffffffff8020c37e>] system_call+0x7e/0x83
    [ 642.286646]
    [ 644.523955] sysfs: duplicate filename 'rfcomm0' can not be created
    [ 644.523965] WARNING: at /build/buildd/linux-2.6.24/fs/sysfs/dir.c:424 sysfs_add_one()
    [ 644.523971] Pid: 8182, comm: rfcomm Tainted: P 2.6.24-16-generic #1
    [ 644.523975]
    [ 644.523975] Call Trace:
    [ 644.524011] [<ffffffff802fe418>] sysfs_add_one+0xb8/0xf0
    [ 644.524020] [<ffffffff802fea30>] create_dir+0x60/0xb0
    [ 644.524036] [<ffffffff802feab1>] sysfs_create_dir+0x31/0x50
    [ 644.524045] [<ffffffff80344912>] kobject_get+0x12/0x20
    [ 644.524052] [<ffffffff80344f23>] kobject_add+0xb3/0x200
    [ 644.524065] [<ffffffff803b7a4f>] device_add+0xcf/0x5d0
    [ 644.524074] [<ffffffff80344912>] kobject_get+0x12/0x20
    [ 644.524087] [<ffffffff803b82c8>] device_create+0xe8/0x140
    [ 644.524099] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 644.524118] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 644.524141] [<ffffffff8039330b>] tty_register_device+0x6b/0x100
    [ 644.524150] [<ffffffff802909e2>] handle_mm_fault+0x1b2/0x7b0
    [ 644.524160] [<ffffffff802a77a7>] kmem_cache_alloc+0x67/0xa0
    [ 644.524167] [<ffffffff802a77a7>] kmem_cache_alloc+0x67/0xa0
    [ 644.524184] [<ffffffff88cd1ed5>] :rfcomm:rfcomm_dev_ioctl+0x5f5/0x730
    [ 644.524196] [<ffffffff80464730>] do_page_fault+0x1d0/0x840
    [ 644.524214] [<ffffffff88ccfd94>] :rfcomm:rfcomm_sock_ioctl+0x34/0x60
    [ 644.524225] [<ffffffff803d792f>] sock_ioctl+0xcf/0x260
    [ 644.524237] [<ffffffff802bb06f>] do_ioctl+0x2f/0xa0
    [ 644.524246] [<ffffffff802bb300>] vfs_ioctl+0x220/0x2c0
    [ 644.524253] [<ffffffff802ab285>] fd_install+0x25/0x60
    [ 644.524264] [<ffffffff802bb431>] sys_ioctl+0x91/0xb0
    [ 644.524278] [<ffffffff8020c37e>] system_call+0x7e/0x83
    [ 644.524298]
    [ 644.524303] kobject_add failed for rfcomm0 with -EEXIST, don't try to register things with the same name in the same directory.
    [ 644.524311] Pid: 8182, comm: rfcomm Tainted: P 2.6.24-16-generic #1
    [ 644.524315]
    [ 644.524315] Call Trace:
    [ 644.524324] [<ffffffff80344fb9>] kobject_add+0x149/0x200
    [ 644.524336] [<ffffffff803b7a4f>] device_add+0xcf/0x5d0
    [ 644.524345] [<ffffffff80344912>] kobject_get+0x12/0x20
    [ 644.524358] [<ffffffff803b82c8>] device_create+0xe8/0x140
    [ 644.524369] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 644.524389] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 644.524409] [<ffffffff8039330b>] tty_register_device+0x6b/0x100
    [ 644.524416] [<ffffffff802909e2>] handle_mm_fault+0x1b2/0x7b0
    [ 644.524425] [<ffffffff802a77a7>] kmem_cache_alloc+0x67/0xa0
    [ 644.524432] [<ffffffff802a77a7>] kmem_cache_alloc+0x67/0xa0
    [ 644.524448] [<ffffffff88cd1ed5>] :rfcomm:rfcomm_dev_ioctl+0x5f5/0x730
    [ 644.524458] [<ffffffff80464730>] do_page_fault+0x1d0/0x840
    [ 644.524476] [<ffffffff88ccfd94>] :rfcomm:rfcomm_sock_ioctl+0x34/0x60
    [ 644.524485] [<ffffffff803d792f>] sock_ioctl+0xcf/0x260
    [ 644.524496] [<ffffffff802bb06f>] do_ioctl+0x2f/0xa0
    [ 644.524505] [<ffffffff802bb300>] vfs_ioctl+0x220/0x2c0
    [ 644.524513] [<ffffffff802ab285>] fd_install+0x25/0x60
    [ 644.524524] [<ffffffff802bb431>] sys_ioctl+0x91/0xb0
    [ 644.524537] [<ffffffff8020c37e>] system_call+0x7e/0x83
    [ 644.524556]
    [ 645.088833] sysfs: duplicate filename 'rfcomm0' can not be created
    [ 645.088843] WARNING: at /build/buildd/linux-2.6.24/fs/sysfs/dir.c:424 sysfs_add_one()
    [ 645.088849] Pid: 8188, comm: rfcomm Tainted: P 2.6.24-16-generic #1
    [ 645.088852]
    [ 645.088853] Call Trace:
    [ 645.088890] [<ffffffff802fe418>] sysfs_add_one+0xb8/0xf0
    [ 645.088899] [<ffffffff802fea30>] create_dir+0x60/0xb0
    [ 645.088914] [<ffffffff802feab1>] sysfs_create_dir+0x31/0x50
    [ 645.088923] [<ffffffff80344912>] kobject_get+0x12/0x20
    [ 645.088931] [<ffffffff80344f23>] kobject_add+0xb3/0x200
    [ 645.088943] [<ffffffff803b7a4f>] device_add+0xcf/0x5d0
    [ 645.088953] [<ffffffff80344912>] kobject_get+0x12/0x20
    [ 645.088966] [<ffffffff803b82c8>] device_create+0xe8/0x140
    [ 645.088978] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 645.088998] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 645.089020] [<ffffffff8039330b>] tty_register_device+0x6b/0x100
    [ 645.089034] [<ffffffff802a77a7>] kmem_cache_alloc+0x67/0xa0
    [ 645.089052] [<ffffffff88cd1ed5>] :rfcomm:rfcomm_dev_ioctl+0x5f5/0x730
    [ 645.089064] [<ffffffff80464730>] do_page_fault+0x1d0/0x840
    [ 645.089082] [<ffffffff88ccfd94>] :rfcomm:rfcomm_sock_ioctl+0x34/0x60
    [ 645.089093] [<ffffffff803d792f>] sock_ioctl+0xcf/0x260
    [ 645.089105] [<ffffffff802bb06f>] do_ioctl+0x2f/0xa0
    [ 645.089114] [<ffffffff802bb300>] vfs_ioctl+0x220/0x2c0
    [ 645.089121] [<ffffffff802ab285>] fd_install+0x25/0x60
    [ 645.089133] [<ffffffff802bb431>] sys_ioctl+0x91/0xb0
    [ 645.089147] [<ffffffff8020c37e>] system_call+0x7e/0x83
    [ 645.089167]
    [ 645.089172] kobject_add failed for rfcomm0 with -EEXIST, don't try to register things with the same name in the same directory.
    [ 645.089179] Pid: 8188, comm: rfcomm Tainted: P 2.6.24-16-generic #1
    [ 645.089183]
    [ 645.089184] Call Trace:
    [ 645.089192] [<ffffffff80344fb9>] kobject_add+0x149/0x200
    [ 645.089204] [<ffffffff803b7a4f>] device_add+0xcf/0x5d0
    [ 645.089213] [<ffffffff80344912>] kobject_get+0x12/0x20
    [ 645.089226] [<ffffffff803b82c8>] device_create+0xe8/0x140
    [ 645.089237] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 645.089257] [<ffffffff80349ca1>] sprintf+0x51/0x60
    [ 645.089277] [<ffffffff8039330b>] tty_register_device+0x6b/0x100
    [ 645.089290] [<ffffffff802a77a7>] kmem_cache_alloc+0x67/0xa0
    [ 645.089306] [<ffffffff88cd1ed5>] :rfcomm:rfcomm_dev_ioctl+0x5f5/0x730
    [ 645.089316] [<ffffffff80464730>] do_page_fault+0x1d0/0x840
    [ 645.089333] [<ffffffff88ccfd94>] :rfcomm:rfcomm_sock_ioctl+0x34/0x60
    [ 645.089343] [<ffffffff803d792f>] sock_ioctl+0xcf/0x260
    [ 645.089355] [<ffffffff802bb06f>] do_ioctl+0x2f/0xa0
    [ 645.089363] [<ffffffff802bb300>] vfs_ioctl+0x220/0x2c0
    [ 645.089370] [<ffffffff802ab285>] fd_install+0x25/0x60
    [ 645.089381] [<ffffffff802bb431>] sys_ioctl+0x91/0xb0
    [ 645.089394] [<ffffffff8020c37e>] system_call+0x7e/0x83
    [ 645.089414]

    Ubuntu Hardy amd64
    Linux m1210 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux

  9. #9
    tavella81's Avatar
    tavella81 no está en línea Stack level 3
    Join Date
    Sep 2007
    So I reinstalled the OS and tried again.

    So it does look like a kernel bug... I was able to connect my Garmin Mobile 10 to via bluetooth using channel 1. I had a message that read:

    root@m1210:~# rfcomm connect 4
    Connected /dev/rfcomm4 to 00:05:4F:08:3B:97 on channel 1
    Press CTRL-C for hangup

    This is the message I expected when I tried to connect to channel 3 on my 8830. I have the following in my /etc/bluetooth/rfcomm.conf:

    rfcomm4 {
    bind yes;
    device 00:05:4F:08:3B:97;
    channel 1;
    comment "Garmin Mobile 10";
    rfcomm0 {
    bind yes;
    device 00:1C:CC:3A:A7:BF;
    channel 3;
    comment "Blackberry DUN";

    So it should have connected to the phone.... I had to reinstall Hardy last night after trying to upgrade to Intrepid.. NIGHTMARE! I guess I could give the 2.6.25 kernel a try at some point over the weekend. It's been so long since I've compiled my own (I'm talking 2.4.xx series).

    [ 6031.541470] kernel BUG at /build/buildd/linux-2.6.24/net/bluetooth/rfcomm/tty.c:313!
    [ 6031.541475] invalid opcode: 0000 [1] SMP
    [ 6031.541479] CPU 1
    [ 6031.541481] Modules linked in: bridge bnep nls_iso8859_1 nls_cp437 vfat fat usb_storage berry_charge libusual af_packet rndis_host cdc_ether usbnet ipv6 vmnet(P) vmblock(P) vmmon(P) rfcomm l2cap ppdev acpi_cpufreq cpufreq_conservative cpufreq_ondemand cpufreq_userspace cpufreq_powersave cpufreq_stats freq_table sbs sbshc dock container iptable_filter ip_tables x_tables sbp2 parport_pc lp parport arc4 ecb blkcipher joydev snd_hda_intel iTCO_wdt snd_pcm_oss snd_mixer_oss iTCO_vendor_support iwl3945 serio_raw hci_usb snd_pcm sdhci ricoh_mmc iwlwifi_mac80211 usbhid bluetooth snd_page_alloc dcdbas evdev mmc_core pcspkr hid snd_hwdep cfg80211 snd_seq_dummy psmouse nvidia(P) i2c_core snd_seq_oss snd_seq_midi snd_rawmidi video output snd_seq_midi_event wmi_acer button battery shpchp snd_seq snd_timer snd_seq_device ac intel_agp pci_hotplug snd soundcore ext3 jbd mbcache sg sr_mod cdrom sd_mod ata_generic ata_piix b44 pata_acpi libata ohci1394 ssb mii ieee1394 scsi_mod ehci_hcd uhci_hcd usbcore thermal processor fan fbcon tileblit font bitblit softcursor fuse
    [ 6031.541577] Pid: 15539, comm: rfcomm Tainted: P 2.6.24-16-generic #1
    [ 6031.541581] RIP: 0010:[<ffffffff88c863bb>] [<ffffffff88c863bb>] :rfcomm:rfcomm_dev_del+0xb/0x60
    [ 6031.541593] RSP: 0018:ffff81003f153e28 EFLAGS: 00010202
    [ 6031.541596] RAX: 000000000000001b RBX: ffff81005e42f840 RCX: 0000000000000000
    [ 6031.541600] RDX: ffff810042329740 RSI: 0000000000000286 RDI: ffff81005e42f840
    [ 6031.541603] RBP: 00000000ffffffed R08: ffffffff8059a3a0 R09: 0000000000000000
    [ 6031.541607] R10: ffff810001013fe0 R11: ffffffff80222fd0 R12: 00007fffa658fc00
    [ 6031.541610] R13: 00000000400452c9 R14: 00000000400452c9 R15: 0000000000000002
    [ 6031.541614] FS: 00007ffc9e5786e0(0000) GS:ffff81007dc01700(0000) knlGS:0000000000000000
    [ 6031.541619] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
    [ 6031.541622] CR2: 00007ffc9decb3c0 CR3: 000000003c535000 CR4: 00000000000006e0
    [ 6031.541625] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
    [ 6031.541629] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
    [ 6031.541632] Process rfcomm (pid: 15539, threadinfo ffff81003f152000, task ffff810042329740)
    [ 6031.541636] Stack: ffff81005e42f840 ffffffff88c86d36 0000000000000000 0000000000000000
    [ 6031.541643] 0000000000000000 ffffffff80464730 000000000000001f ffff81007c231400
    [ 6031.541649] 00007fffa658fc00 00007fffa658fc00 00000000400452c9 00000000400452c9
    [ 6031.541654] Call Trace:
    [ 6031.541663] [<ffffffff88c86d36>] :rfcomm:rfcomm_dev_ioctl+0x456/0x730
    [ 6031.541674] [<ffffffff80464730>] do_page_fault+0x1d0/0x840
    [ 6031.541686] [<ffffffff88c84d94>] :rfcomm:rfcomm_sock_ioctl+0x34/0x60
    [ 6031.541695] [<ffffffff803d792f>] sock_ioctl+0xcf/0x260
    [ 6031.541706] [<ffffffff802bb06f>] do_ioctl+0x2f/0xa0
    [ 6031.541712] [<ffffffff802bb300>] vfs_ioctl+0x220/0x2c0
    [ 6031.541719] [<ffffffff802ab285>] fd_install+0x25/0x60
    [ 6031.541727] [<ffffffff802bb431>] sys_ioctl+0x91/0xb0
    [ 6031.541737] [<ffffffff8020c37e>] system_call+0x7e/0x83
    [ 6031.541751]
    [ 6031.541753]
    [ 6031.541753] Code: 0f 0b eb fe f0 0f ba 6f 28 04 48 c7 c7 a0 d1 c8 88 e8 3f c5
    [ 6031.541765] RIP [<ffffffff88c863bb>] :rfcomm:rfcomm_dev_del+0xb/0x60
    [ 6031.541772] RSP <ffff81003f153e28>
    [ 6031.541786] ---[ end trace 541aeb858884a6cf ]---

    Anyone else seeing this running Ubuntu Hardy or 2.4.24?

  10. #10
    bdharjo's Avatar
    bdharjo no está en línea Stack level 1
    Join Date
    Apr 2008
    Hello all, just want to share..

    After several trial and error, I could manage my BB Curve 8310 as bluetooth modem on my Ubuntu Hardy box....

    Visit HERE for complete story

    have fun

  11. #11
    Assellascedge's Avatar
    Assellascedge no está en línea Stack level 1
    Join Date
    Jul 2009

    Bluetooth DUN tethering

    I have quite a similiar problem with my 818pro with Itech ClipII mini. It wont disconnect by itself but it will not autoconnect again after the bluetooth is swtich On. I have to go to my PDA bluetooth settings to scan and reconnect everytime this happen.How to solve?

  12. #12
    iTechHellas's Avatar
    iTechHellas no está en línea Stack level 1
    Join Date
    Aug 2009
    Quote Originally Posted by Assellascedge View Post
    I have quite a similiar problem with my 818pro with Itech ClipII mini. It wont disconnect by itself but it will not autoconnect again after the bluetooth is swtich On. I have to go to my PDA bluetooth settings to scan and reconnect everytime this happen.How to solve?
    Dear User try reconnecting by pressing the MFB button once. This should give an order to your Handset to connect again. You can do this while talking too and the speech should pass to the ClipIImini.
    Last edited by iTechHellas; 08-10-2009 at 04:08 AM.
    i.Tech Hellas support team |

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts