Results 1 to 6 of 6

Anyone here with the new Curve from Telus experiencing GPS problems with BB Maps and ... BlackBerry GPS forum

  1. #1
    ERShotty's Avatar
    ERShotty no está en línea Stack level 2
    Join Date
    Dec 2007

    Telus Curve 8330 GPS problems


    Anyone here with the new Curve from Telus experiencing GPS problems with BB Maps and other 3rd party apps (other then Telus Navigator, which seems to work 99% of the time)?

    I literally have to do a reset everytime I want to use it. Although I've noticed that sometimes, and I do mean some of the time, that using Telus Navigator helps.... "boost" the GPS into working?

    Another crappy thing that I've also noticed is that Google Maps has no GPS functionality at all. All I can get with that is Tower Triangulation and an accuracy of within 1700 metres.

    Using GPSed also helps as it serves as the "Refresh GPS" option that our Curves lack.
    Ernest Rosales
    Windows Live:

  2. #2
    setacity's Avatar
    setacity no está en línea Stack level 1
    Join Date
    May 2008
    I am also experiencing this problem with my Telus Blackberry Curve 8330. My OS is
    Google Maps says "accurate within 1700 meters". Sometimes it isn't even within 1700 meters.
    Blackberry Maps says "searching for satelites", but never does anything else.
    Telus Navigator says "searching for satelites", but never does anything else.

    I have phoned Telus. The guy that I talked to at Telus tried one of his phones, and it didn't work either. His documentation showed that the Curve has to have Telus Navigator installed before BB Maps will work, but even then BB Maps was reported to have taken 8 minutes to find current location.

    According to Telus, the Google Maps version for the CDMA 8330 does not use real GPS, but rather it uses cell tower triangulation, which is why it always says 1700meters. Apparently Google is working on a fix, but that is only according to Telus.

    Their documentation also showed that running Telus Navigator in the background would enable BB Maps to work, but neither the Telus guy nor I could get that to work.

    Telus has now created a "ticket" to troubleshoot the issue further.

  3. #3
    Leetneo's Avatar
    Leetneo no está en línea Stack level 4
    Join Date
    Aug 2007
    Mine worked fine for the 3 weeks I used her, all my co-workers have em and don't have a prob, they think im odd for going back the the WE...HAHA!
    Last edited by Leetneo; 05-30-2008 at 01:12 AM. Reason: Spelling...

  4. #4
    tavella81's Avatar
    tavella81 no está en línea Stack level 3
    Join Date
    Sep 2007
    The Google maps not using GPS appears to have started when they release version 2.1.0. The older version appears to have worked fine. I'm going to pull the .cod off my old 8830 and see if I can get it to work properly.

  5. #5
    GeneKam's Avatar
    GeneKam no está en línea Stack level 4
    Join Date
    Apr 2007
    mine doesent work period!
    "Drive by tornado-kicking, boy, i wish i could see that" - Yaku
    "Yeah! It was epic" - Gene

  6. #6
    jaypee42's Avatar
    jaypee42 no está en línea Stack level 1
    Join Date
    Feb 2008
    I am finding the same thing with my new TELUS Curve 8330. I switched from a TELUS 8830 World Edition that had no GPS issues at all.

    I now find that when I go into Google Maps I get the default 1700 m circle as if I am just using cell tower location.

    The work around I have found is that if I switch to BBMaps - then let it wait a LOooooong time to search for satellites and start GPS navigation - then switch to Google Maps - Google Maps will recognize the GPS is started and behave properly.

    I don't have the TELUS Navigator installed at all - didn't like it.

    I hope this is fixed soon as I don't like having to keep BBMaps around just to bootstrap the Google Maps into working!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts