Page 2 of 19 FirstFirst 1234567 ... LastLast
Results 16 to 30 of 283

Here's the latest build... should work on OS 4.2 - 4.7 devices. Use desktop manager ... 3rd Party BlackBerry Software forum

  1. #16
    cwrchris's Avatar
    cwrchris no está en línea Developer
    Join Date
    Nov 2008
    Posts
    54

    Podcasts 0.5.5

    Advertisement



    Here's the latest build... should work on OS 4.2 - 4.7 devices. Use desktop manager to sideload it. Few notes:
    • An SD card is required and it will put files in /Blackberry/music/Podcasts
    • Direct TCP is required because BIS has a file-size limit (and I don't want to work around it right now.) On CDMA devices you should be fine, on GSM make sure your APN is setup properly
    • Unlimited data plan highly recommended
    • This build expires on Jan 1 2009. I'll have a newer build available before then.
    • There will be bugs!
    Bug reports and any feedback you have would be greatly appreciated. Few things I know I want to add:
    • A nice looking add screen instead of the ugly dialog it is now
    • Scheduling (check for new items daily/weekly and auto-download)
    • Better display when errors occur
    • Auto-restart of downloads if they get interrupted
    • Built-in podcast player so you can listen while downloading/streaming (maybe)
    Attached Files Attached Files

  2. #17
    cwrchris's Avatar
    cwrchris no está en línea Developer
    Join Date
    Nov 2008
    Posts
    54
    Quote Originally Posted by mikedoan View Post
    I'm in (PM'd you)
    Tried to respond, but apparently I need 10 posts first. Pls find link in previous post.

  3. #18
    j llama's Avatar
    j llama no está en línea Device Pro
    Join Date
    Sep 2006
    PIN/ID
    4U2ASKME
    Posts
    4,319
    I'll check this out later when I get home.

    Best way for exposure is to post an OTA link, just letting ya know
    BlackBerry® Certified Support Specialist

  4. #19
    cwrchris's Avatar
    cwrchris no está en línea Developer
    Join Date
    Nov 2008
    Posts
    54
    Quote Originally Posted by j llama View Post
    I'll check this out later when I get home.

    Best way for exposure is to post an OTA link, just letting ya know
    Yeah sorry about that.. my hosting provider's server won't host JAD files for some reason. I'm working with their support to get it fixed.

  5. #20
    Jey08's Avatar
    Jey08 no está en línea Developer
    Join Date
    Dec 2008
    Posts
    87
    compare with BerryTunes, benefits ?

    is your app better and why ?

  6. #21
    cwrchris's Avatar
    cwrchris no está en línea Developer
    Join Date
    Nov 2008
    Posts
    54
    Quote Originally Posted by Jey08 View Post
    compare with BerryTunes, benefits ?
    is your app better and why ?
    I haven't used BerryTunes other than one or two times. I wasn't a big fan of the interface, i couldn't figure out how to subscribe to my own RSS urls, and i never quite got it to fully work.

  7. #22
    jblackfish's Avatar
    jblackfish no está en línea PINStacked!
    Join Date
    Dec 2007
    Posts
    11,116
    chris, When I tried to add new feed and key in the address, the ONLY thing I was unable to do was put the "=" sign in the address. I pressed the symbol key (normally) and tried to select it using both the trackball AND the "y" key and NOTHING happened. I use symbols all the time so I know how to do that - never had that happen before now - ever! Have you had this problem?

    I'm 8330 using OS 4.5.0.77.
    For every complex problem there is a solution, that is simple, neat, .....and wrong! (H. L. Mencken) jblackfish(at)pinstack(dot)com

  8. #23
    jblackfish's Avatar
    jblackfish no está en línea PINStacked!
    Join Date
    Dec 2007
    Posts
    11,116
    Also tried emailing the address to myself and copy/pasting it but there's no paste function on the add new feed screen.
    For every complex problem there is a solution, that is simple, neat, .....and wrong! (H. L. Mencken) jblackfish(at)pinstack(dot)com

  9. #24
    Jbee's Avatar
    Jbee no está en línea Stack level 5
    Join Date
    Dec 2007
    PIN/ID
    3047D925
    Posts
    1,859
    Quote Originally Posted by j llama View Post
    More than happy to beta test on the Storm.

    Ditto!

  10. #25
    cwrchris's Avatar
    cwrchris no está en línea Developer
    Join Date
    Nov 2008
    Posts
    54

    Podcasts 0.5.8

    Quote Originally Posted by jblackfish View Post
    Also tried emailing the address to myself and copy/pasting it but there's no paste function on the add new feed screen.
    That was a bug in the add feed popup. I made a proper add feed screen and it should work fine with symbols, copy/paste, and suretype now. Please try the attached files (still working on OTA hosting..)

    BTW this includes a storm-compatible version, and don't forget to make sure your APN is setup (BB Options > Advanced > TCP) if you have a GSM device.
    Attached Files Attached Files
    Last edited by cwrchris; 12-02-2008 at 08:59 PM.

  11. #26
    jblackfish's Avatar
    jblackfish no está en línea PINStacked!
    Join Date
    Dec 2007
    Posts
    11,116
    That took care of it. Thanks Chris.
    For every complex problem there is a solution, that is simple, neat, .....and wrong! (H. L. Mencken) jblackfish(at)pinstack(dot)com

  12. #27
    j llama's Avatar
    j llama no está en línea Device Pro
    Join Date
    Sep 2006
    PIN/ID
    4U2ASKME
    Posts
    4,319
    Quote Originally Posted by cwrchris View Post

    BTW this includes a storm-compatible version
    Whoo hoo!
    Last edited by j llama; 12-03-2008 at 10:22 AM.
    BlackBerry® Certified Support Specialist

  13. #28
    tvwebguy's Avatar
    tvwebguy no está en línea Stack level 2
    Join Date
    Apr 2008
    Posts
    18
    Got it. Trying it out. Thanks!

  14. #29
    jblackfish's Avatar
    jblackfish no está en línea PINStacked!
    Join Date
    Dec 2007
    Posts
    11,116
    Chris, Downloaded podcast to media card, started playing it and it worked great.

    Then I paused it and "escape-key" back to the previous page. When I try to go back and resume playing by selecting the same podcast, the media player screen displays for an instant and then immediately returns to the podcast list page, over and over each time I repeat the select.

    If I press menu>exit it starts playing, from the beginning, again - that over and over and eventually I can "exit" and "close" my way out of it after several attempts. It just won't pause and return without problems. Is my description that clear enough?

    Any help with that? I assume that it's supposed to work with the media player that's with the OS.
    Last edited by jblackfish; 12-05-2008 at 04:20 PM.
    For every complex problem there is a solution, that is simple, neat, .....and wrong! (H. L. Mencken) jblackfish(at)pinstack(dot)com

  15. #30
    cwrchris's Avatar
    cwrchris no está en línea Developer
    Join Date
    Nov 2008
    Posts
    54
    Quote Originally Posted by jblackfish View Post
    Any help with that? I assume that it's supposed to work with the media player that's with the OS.
    Yeah i've seen a lot of problems with the native media player... it looks like it's actually making a new instance of the media player (you can ALT-BACK switch to it, and it has a default icon) instead of actually using the regular media player. Resuming, background operation, and closing it all seem to be behaving badly.

    The feature to launch that the media player from a 3rd party app was only added in 4.3, and I have a feeling it wasn't fully baked.

    I'm writing a player that will be built into the podcast app that will also fully support streaming (so you can play while downloading.) I think that looks like the only way for now...

Page 2 of 19 FirstFirst 1234567 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •